牛骨文教育服务平台(让学习变的简单)
/*
时间:2012.03.17
作者:烟大洋仔
题目:
	Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output
Print the total time on a single line for each test case. 

Sample Input
1 2
3 2 3 1
0
 

Sample Output
17
41
题目分析:
	最初的时候竟然忘记了数组赋值整了老半天,通过几个for循环在加上数组的循环判断即可解决;竟然在这里浪费了半天的时间气人

*/
#include <iostream>
using namespace std;
int main()
{
     int n,a[100],i=0,sum=0;
    while (cin>>n&&n!=0)
    {
            a[0]=0;
            sum=0;
            for(i=1;i<=n;i++)
            cin>>a[i];
        for (i=1;i<=n;i++)
        {
            if(a[i]>a[i-1])
                sum=sum+(a[i]-a[i-1])*6+5;
            else
                sum=sum+(a[i-1]-a[i])*4+5;
        }
        cout<<sum<<endl;
    }
    return 0;

}