牛骨文教育服务平台(让学习变的简单)
# As Easy As A+B
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)  
Total Submission(s): 48014    Accepted Submission(s): 20587  

Problem Description

These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!

Input

Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line. 
It is guarantied that all integers are in the range of 32-int.

Output

For each case, print the sorting result, and one line one case.

Sample Input

2
3 2 1 3
9 1 4 7 2 5 8 3 6 9

Sample Output

1 2 3
1 2 3 4 5 6 7 8 9

题目的大意为:第一行输入你要输入几行的数据,然后第一列的数据是表示本行上有多少个数据,对其进行排序即可

import java.util.ArrayList;
import java.util.HashSet;
import java.util.List;
import java.util.Scanner;
import java.util.Set;

public class Main {

	public static void main(String[] args) {
		Scanner scanner = new Scanner(System.in);
		int num = scanner.nextInt();
		int i = 0, j = 0, num2 = 0, m = 0, num3 = 0;
		List listTemp = new ArrayList();
		Object[] object = new Object[num];
		while(i < num)
		{
			num2 = scanner.nextInt();
			
			List list = new ArrayList();
			object[i] = new Object();
			
			for(j = 0; j < num2; j++)
			{
				num3 = scanner.nextInt();
				list.add(num3);
			}
			list = sort2(list.toArray());
			object[i] = list;
			
			i++;
		}
		for(i = 0; i < object.length; i++)
		{
			listTemp = (List) object[i];
			for(j = 0; j < listTemp.size(); j++)
			{
				if(j == 0)
					System.out.print(listTemp.get(j));
				else
					System.out.print(" " + listTemp.get(j));
			}
			System.out.println();
		}
	}

	private static List sort2(Object[] objects) {
		List listTemp = new ArrayList();
		int num1, num2, temp;
		Object obj = null;
		for(int i = 0; i < objects.length; i++)
		{
			num1 = Integer.parseInt(objects[i].toString());
			for(int j = i; j < objects.length; j++)
			{
				num2 = Integer.parseInt(objects[j].toString());
				if(num1 > num2)
				{
					temp = num1;
					num1 = num2;
					num2 = temp;
					
					obj = objects[i];
					objects[i] = objects[j];
					objects[j] = obj;
					
				}
			}
			listTemp.add(num1);
		}
		//System.out.println(listTemp);
		return listTemp;
	}

}