ACM杭电的1093求和问题

/*
时间:
	20120314
作者:
	烟大洋仔
题目:
	Problem DescriptionYour task is to calculate the sum of some integers.

InputInput contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 

OutputFor each group of input integers you should output their sum in one line, and with one line of output for each line in input. 

Sample Input24 1 2 3 45 1 2 3 4 5 

Sample Output1015

题目分析:
	本题结合了之前做过的几个答题;
	一个是控制数据的组数;2是控制数据的输入个数;三是输出结果
	本题通过了三重循环;一重呢是输入组数的;二重是控制数据的计算的	个数的;三重呢就是控制输出结果的
*/
#include <iostream>
using namespace std;
int main()
{
    int n,m,a,sum=0;
    while(cin>>n)
    {
        while (n--)
        {
            cin>>m;
            sum=0;
            while(m--)
            {
                cin>>a;
                sum=sum+a;
            }
            cout<<sum<<endl;
        }

    }

    return 0;

}

文章导航