杭电ACM1004

/*
时间:
	2013.03.26
作者:
	烟大洋仔
题目:
Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges" favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
 
Sample Output
red
pink
题目分析:
	该题目的意思为:让你输入固定个数的颜色然后统计输入颜色最多的颜色名称
*/
#include <iostream>
#include <string.h>
using namespace std;
int main(){
	int n,a[1000],max,i;
	char s[1000][16];
	while (cin>>n&&n!=0)
	{
        for (i=0;i<n;i++)
        cin>>s[i];
        for(i=0,max=0;i<n;i++)
        {
            a[i]=0;
            for(int j=i+1;j<n;j++)
            {
                if(strcmp(s[i],s[j])==0)
                a[i]++;
            }
            if(a[i]>max)
            max=a[i];

        }
        for(i=0;i<n;i++)
        {

            if(a[i]==max)
            cout<<s[i]<<endl;
        }

	}
	return 0;
}

 

文章导航