牛骨文教育服务平台(让学习变的简单)
# A + B Problem II
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)  
Total Submission(s): 273307    Accepted Submission(s): 52784  
  

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

import java.math.BigDecimal;
import java.util.Scanner;

// 代码提交时改为Main且去掉当前文件的包名
public class Main {

	public static void main(String[] args) {

		/**
		 * 从题目中可以看出来,数据比较大,只是用普通的整形或者别的恐怕是无能为力,不过BigDecimal对于数据较大的数处理十分的方便
		 * 而且封装好了函数只需要调用就可以了
		 */
		Scanner scanner = new Scanner(System.in);
		int num = scanner.nextInt();
		// 这里的二维数组也需要有些讲究,一般一行中查找不同的列的速度要比一列中查找不同的行的数据要快
		BigDecimal[][] bigNum = new BigDecimal[num][2];
 		for(int i = 0; i < num; i++)
		{
			bigNum[i][0] = scanner.nextBigDecimal();
			bigNum[i][1] = scanner.nextBigDecimal();
		}
 		// 输出的时候注意空格,以及的空行
 		for(int j = 0; j < num; j++)
 		{
 			if(j != 0)
 				System.out.println();
 			System.out.println("Case "+(j+1)+":");
 			System.out.println(bigNum[j][0] +" + "+ bigNum[j][1]+" = "+ bigNum[j][0].add(bigNum[j][1]));
 		}
	}

}